Discussion:
Bug#866641: guitarix: depends on libwebkitgtk-1.0-0 which is deprecated
(too old to reply)
Jeremy Bicha
2017-06-30 15:44:57 UTC
Permalink
Raw Message
Package: guitarix
Severity: serious
Tags: sid buster
User: pkg-webkit-***@lists.alioth.debian.org
Usertags: oldlibs libwebkitgtk-1.0-0 webkit1

Hi,

guitarix depends on libwebkitgtk-1.0-0, which is deprecated in
favor of libwebkit2gtk-4.0-37 (provided in Debian by webkit2gtk).
guitarix should be ported to the new webkitgtk version so we can
remove the old, unmaintained one.

Please try to do soon as we're going to try to remove the old webkitgtk soon.

I am filing this bug as "serious" since the old webkitgtk will not be
available in the next major stable release of Debian (codenamed
"buster").

If you have any question don't hesitate to ask.

On behalf of the Debian WebKit Maintainers,
Jeremy Bicha
Hermann Meyer
2017-07-01 07:44:52 UTC
Permalink
Raw Message
Hi

Any plans to provide webkit2 with gtk2 support, e.g. build with |

--with-gtk=2.|0

regards
hermann|||


|
Jeremy Bicha
2017-07-01 11:28:58 UTC
Permalink
Raw Message
Post by Hermann Meyer
Any plans to provide webkit2 with gtk2 support, e.g. build with |
No, sorry. gtk3 has stabilized now with version 3.22.* So it's a great
time to upgrade your app. gtk3 natively supports Hi-DPI and GNOME on
Wayland.

Thanks,
Jeremy Bicha
Hermann Meyer
2017-07-01 12:32:19 UTC
Permalink
Raw Message
Post by Jeremy Bicha
Post by Hermann Meyer
Any plans to provide webkit2 with gtk2 support, e.g. build with |
No, sorry. gtk3 has stabilized now with version 3.22.* So it's a great
time to upgrade your app. gtk3 natively supports Hi-DPI and GNOME on
Wayland.
Thanks,
Jeremy Bicha
Thanks, a pity.
I don't think that gtk2 will be skipped for the next stable release.
Here are no plans to upgrade to gtk3 at any time soon.
But webkit is a optional dependency. If webkit isn't found,
or disabled by configure, this feature will simple be disabled.

regards
hermann
Hermann Meyer
2017-07-05 08:08:28 UTC
Permalink
Raw Message
Hi


So I've now removed webkit from guitarix.

Next release will come without webkit, but a new online preset fetcher
(Gio::File) and menu.


regards

hermann
Hermann Meyer
2017-07-15 03:27:18 UTC
Permalink
Raw Message
And a new release is out, 0.35.4, which dropping the dependency to
libwebkitgtk at all.

https://sourceforge.net/projects/guitarix/
Debian Bug Tracking System
2017-08-12 00:21:20 UTC
Permalink
Raw Message
Your message dated Sat, 12 Aug 2017 00:19:33 +0000
with message-id <E1dgK9N-0000Pf-***@fasolo.debian.org>
and subject line Bug#866641: fixed in guitarix 0.35.6-1
has caused the Debian Bug report #866641,
regarding guitarix: depends on libwebkitgtk-1.0-0 which is deprecated
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ***@bugs.debian.org
immediately.)
--
866641: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=866641
Debian Bug Tracking System
Contact ***@bugs.debian.org with problems
Loading...