Discussion:
Bug#868387: gwc: Please drop the (build-)dependency against gnome-vfs
(too old to reply)
b***@debian.org
2017-07-15 11:40:01 UTC
Permalink
Raw Message
Source: gwc
Version: 0.21.19~dfsg0-5
Severity: wishlist
Tags: sid buster
User: pkg-gnome-***@lists.alioth.debian.org
Usertags: gnome-vfs-removal oldlibs

Dear maintainer,

Your package is {build-}depending against gnome-vfs which is
deprecated for quite some times now and has been replaced by gvfs.

We are thinking about removing gnome-vfs for Buster if possible.

Could you please verify that this dependency is mandatory and if it's
not the case, could you please remove it?

Don't hesitate to contact me if you have any questions.

Kind regards,

Laurent Bigonville
Jaromír Mikeš
2017-07-17 07:51:13 UTC
Permalink
Raw Message
2017-07-15 13:40 GMT+02:00 <***@debian.org>:

Hi Laurent,

Your package is {build-}depending against gnome-vfs which is
Post by b***@debian.org
deprecated for quite some times now and has been replaced by gvfs.
I've checked B-D of gwc package:

Build-Depends:
debhelper (>= 10),
libasound2-dev,
libfftw3-dev,
libgnome2-dev,
libgnomeui-dev,
libpulse-dev,
libsndfile1-dev,
libvorbis-dev

There is no direct B-D on gnome-vfs, but libgnome2-dev need it I guess.
Post by b***@debian.org
Don't hesitate to contact me if you have any questions.
There is upstream effort to switch to gnome3 what should fix this problem
if I understand right.
I am copying upstream devs so they are aware of this issue.

best regards

mira
Laurent Bigonville
2017-07-17 08:25:55 UTC
Permalink
Raw Message
Post by Jaromír Mikeš
Hi Laurent,
Your package is {build-}depending against gnome-vfs which is
deprecated for quite some times now and has been replaced by gvfs.
debhelper (>= 10),
libasound2-dev,
libfftw3-dev,
libgnome2-dev,
libgnomeui-dev,
libpulse-dev,
libsndfile1-dev,
libvorbis-dev
There is no direct B-D on gnome-vfs, but libgnome2-dev need it I guess.
Yes that dependency is indeed pulled by libgnome2 (which is also
deprecated) I was not expecting it to leak the dependency like that TBH
Post by Jaromír Mikeš
Don't hesitate to contact me if you have any questions.
There is upstream effort to switch to gnome3 what should fix this
problem if I understand right.
I am copying upstream devs so they are aware of this issue.
Yes, removing these gnome2 library will fix this bug (and make the
Debian GNOME team really happy)

Regards,

Laurent Bigonville
Post by Jaromír Mikeš
best regards
mira
Debian Bug Tracking System
2017-07-18 23:36:16 UTC
Permalink
Raw Message
Your message dated Tue, 18 Jul 2017 23:34:00 +0000
with message-id <E1dXc08-000DGH-***@fasolo.debian.org>
and subject line Bug#868387: fixed in gwc 0.22-1
has caused the Debian Bug report #868387,
regarding gwc: Please drop the (build-)dependency against gnome-vfs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ***@bugs.debian.org
immediately.)
--
868387: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=868387
Debian Bug Tracking System
Contact ***@bugs.debian.org with problems
Loading...