Discussion:
Bug#868236: vlc-plugin-base: Contains out-dated plugin VLSub which has up-to date dedicated package vlc-plugin-vlsub
(too old to reply)
Tomas Safarik
2017-07-13 13:17:51 UTC
Permalink
Raw Message
Package: src:vlc
Version: 2.2.6-2+b3
Severity: normal

Dear Maintainer,

this package installs out-dated version of VLSub plugin under:

/usr/lib/x86_64-linux-gnu/vlc/lua/extensions/VLSub.luac

This plugin has its own dedicated package vlc-plugin-vlsub which has
more up-to date version.

Maybe the file should be removed from this package and the package
vlc-plugin-vlsub be made as Recommended or Depend to vlc-plugin-base.

Regards,

Tomas

-- System Information:
Debian Release: buster/sid
APT prefers testing
APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.11.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8), LANGUAGE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages vlc-plugin-base depends on:
ii liba52-0.7.4 0.7.4-19
ii libasound2 1.1.3-5
ii libass9 1:0.13.7-2
ii libavahi-client3 0.6.32-2
ii libavahi-common3 0.6.32-2
ii libavc1394-0 0.5.4-4+b1
ii libbasicusageenvironment1 2016.11.28-1
ii libbluray2 1:1.0.1.deb1-2
ii libbz2-1.0 1.0.6-8.1
ii libc6 2.24-12
ii libcairo2 1.14.10-1
ii libcddb2 1.3.2-5
ii libcdio13 0.83-4.3+b1
ii libchromaprint1 1.4.2-1
ii libcrystalhd3 1:0.0~git20110715.fdd2f19-12
ii libdbus-1-3 1.10.20-1
ii libdc1394-22 2.2.5-1
ii libdca0 0.0.5-10
ii libdirectfb-1.2-9 1.2.10.0-9
ii libdvbpsi10 1.3.1-2
ii libdvdnav4 5.0.3-3
ii libdvdread4 5.0.3-2
ii libebml4v5 1.3.4-1
ii libfaad2 2.8.0~cvs20161113-1
ii libflac8 1.3.2-1
ii libfontconfig1 2.12.3-0.2
ii libfreetype6 2.8-0.2
ii libfribidi0 0.19.7-1+b1
ii libgcc1 1:7.1.0-9
ii libgcrypt20 1.7.8-2
ii libglib2.0-0 2.52.3-1
ii libgme0 0.6.1-1
ii libgnutls30 3.5.13-2
ii libgpg-error0 1.27-3
ii libgroupsock8 2016.11.28-1
ii libgsm1 1.0.13-4+b2
ii libjpeg62-turbo 1:1.5.1-2
ii libkate1 0.4.1-7+b1
ii liblirc-client0 0.9.4c-9
ii liblivemedia57 2016.11.28-1
ii liblua5.2-0 5.2.4-1.1+b2
ii liblzma5 5.2.2-1.2+b1
ii libmad0 0.15.1b-8
ii libmatroska6v5 1.4.7-2
ii libmp3lame0 3.99.5+repack1-9+b2
ii libmpcdec6 2:0.1~r495-1+b1
ii libmpeg2-4 0.5.1-7+b2
ii libmtp9 1.1.13-1
ii libncursesw5 6.0+20170708-1
ii libogg0 1.3.2-1
ii libopenmpt-modplug1 0.2.8414~beta25-1
ii libopus0 1.2~alpha2-1
ii libpng16-16 1.6.29-3
ii libpulse0 10.0-2
ii libraw1394-11 2.1.2-1+b1
ii libresid-builder0c2a 2.1.1-15
ii librsvg2-2 2.40.16-1+b1
ii librtmp1 2.4+20151223.gitfa8646d.1-1+b1
ii libsamplerate0 0.1.8-8+b2
ii libsdl-image1.2 1.2.12-5+b8
ii libsdl1.2debian 1.2.15+dfsg1-4
ii libshine3 3.1.0-5
ii libshout3 2.3.1-3
ii libsidplay2 2.1.1-15
ii libsnappy1v5 1.1.4-3
ii libsndio6.1 1.1.0-3
ii libspeex1 1.2~rc1.2-1+b2
ii libspeexdsp1 1.2~rc1.2-1+b2
ii libssh-gcrypt-4 0.7.5-1
ii libssh2-1 1.8.0-1
ii libstdc++6 7.1.0-9
ii libtag1v5 1.11.1+dfsg.1-0.1
ii libtheora0 1.1.1+dfsg.1-14+b1
ii libtinfo5 6.0+20170708-1
ii libtwolame0 0.3.13-2
ii libudev1 233-10
ii libupnp6 1:1.6.19+git20160116-1.2
ii libusageenvironment3 2016.11.28-1
ii libva-drm1 1.8.3-1
ii libva-x11-1 1.8.3-1
ii libva1 1.8.3-1
ii libvcdinfo0 0.7.24+dfsg-0.2
ii libvlccore8 2.2.6-2+b3
ii libvorbis0a 1.3.5-4
ii libvorbisenc2 1.3.5-4
ii libvpx4 1.6.1-3
ii libwavpack1 5.1.0-1
ii libwebp6 0.5.2-1
ii libwebpmux2 0.5.2-1
ii libx11-6 2:1.6.4-3
ii libx264-148 2:0.148.2795+gitaaa9aa8-1
ii libx265-116 2.4-2
ii libxcb-keysyms1 0.4.0-1+b2
ii libxcb1 1.12-1
ii libxml2 2.9.4+dfsg1-3
ii libxvidcore4 2:1.3.4-1+b2
ii libzvbi0 0.2.35-13
ii vlc-data 2.2.6-2
ii zlib1g 1:1.2.8.dfsg-5

Versions of packages vlc-plugin-base recommends:
ii xdg-utils 1.1.1-1

Versions of packages vlc-plugin-base suggests:
pn libdvdcss2 <none>

Versions of packages libvlc-bin depends on:
ii libc6 2.24-12
ii libvlc5 2.2.6-2+b3

Versions of packages libvlc5 depends on:
ii libc6 2.24-12
ii libvlccore8 2.2.6-2+b3

Versions of packages libvlc5 recommends:
ii libvlc-bin 2.2.6-2+b3

Versions of packages libvlccore8 depends on:
ii libc6 2.24-12
ii libdbus-1-3 1.10.20-1
ii libidn11 1.33-1

Versions of packages libvlccore8 recommends:
pn libproxy-tools <none>

Versions of packages vlc depends on:
ii vlc-bin 2.2.6-2+b3
ii vlc-l10n 2.2.6-2
ii vlc-plugin-qt 2.2.6-2+b3
ii vlc-plugin-video-output 2.2.6-2+b3

Versions of packages vlc recommends:
ii vlc-plugin-notify 2.2.6-2+b3
ii vlc-plugin-samba 2.2.6-2+b3
ii vlc-plugin-skins2 2.2.6-2+b3
ii vlc-plugin-video-splitter 2.2.6-2+b3
ii vlc-plugin-visualization 2.2.6-2+b3

Versions of packages vlc-bin depends on:
ii libc6 2.24-12
ii libvlc-bin 2.2.6-2+b3
ii libvlc5 2.2.6-2+b3

Versions of packages vlc-plugin-notify depends on:
ii libc6 2.24-12
ii libgdk-pixbuf2.0-0 2.36.5-2
ii libglib2.0-0 2.52.3-1
ii libgtk2.0-0 2.24.31-2
ii libnotify4 0.7.7-2
ii libvlccore8 2.2.6-2+b3

Versions of packages vlc-plugin-qt depends on:
ii libc6 2.24-12
ii libgcc1 1:7.1.0-9
ii libqt5core5a 5.7.1+dfsg-4
ii libqt5gui5 5.7.1+dfsg-4
ii libqt5widgets5 5.7.1+dfsg-4
ii libqt5x11extras5 5.7.1~20161021-2
ii libstdc++6 7.1.0-9
ii libvlccore8 2.2.6-2+b3
ii libx11-6 2:1.6.4-3
ii libxi6 2:1.7.9-1

Versions of packages vlc-plugin-qt recommends:
ii vlc-bin 2.2.6-2+b3

Versions of packages vlc-plugin-skins2 depends on:
ii fonts-freefont-ttf 20120503-6
ii libc6 2.24-12
ii libfreetype6 2.8-0.2
ii libfribidi0 0.19.7-1+b1
ii libgcc1 1:7.1.0-9
ii libstdc++6 7.1.0-9
ii libvlccore8 2.2.6-2+b3
ii libx11-6 2:1.6.4-3
ii libxext6 2:1.3.3-1+b2
ii libxinerama1 2:1.1.3-1+b3
ii libxpm4 1:3.5.12-1
ii vlc-plugin-qt 2.2.6-2+b3
ii zlib1g 1:1.2.8.dfsg-5

Versions of packages vlc-plugin-skins2 recommends:
ii vlc-bin 2.2.6-2+b3

Versions of packages vlc-plugin-video-output depends on:
ii libaa1 1.4p5-44+b1
ii libc6 2.24-12
ii libcaca0 0.99.beta19-2+b2
ii libegl1-mesa [libegl1-x11] 13.0.6-1+b2
ii libgl1-mesa-glx [libgl1] 13.0.6-1+b2
ii libgles2-mesa [libgles2] 13.0.6-1+b2
ii libvlccore8 2.2.6-2+b3
ii libx11-6 2:1.6.4-3
ii libxcb-keysyms1 0.4.0-1+b2
ii libxcb-shm0 1.12-1
ii libxcb-xv0 1.12-1
ii libxcb1 1.12-1

Versions of packages vlc-plugin-video-splitter depends on:
ii libc6 2.24-12
ii libvlccore8 2.2.6-2+b3
ii libxcb-randr0 1.12-1
ii libxcb1 1.12-1

Versions of packages vlc-plugin-visualization depends on:
ii libc6 2.24-12
ii libgl1-mesa-glx [libgl1] 13.0.6-1+b2
ii libvlccore8 2.2.6-2+b3

-- no debconf information

Loading...